Du bist nicht angemeldet.

Lieber Besucher, herzlich willkommen im Patrizierforum. Falls dies Dein erster Besuch auf dieser Seite ist, lies bitte die Hilfe durch. Dort wird Dir die Bedienung dieser Seite näher erläutert. Darüber hinaus solltest Du Dich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutze das Registrierungsformular, um Dich zu registrieren oder informiere Dich ausführlich über den Registrierungsvorgang. Falls Du Dich bereits zu einem früheren Zeitpunkt registriert hast, kannst Du Dich hier anmelden.

knoll3

Kaufmann

  • »knoll3« ist männlich

Beiträge: 245

Dabei seit: 25. August 2011

Wohnort: Südlich der Hansestädte

  • Private Nachricht senden

41

Mittwoch, 18. September 2013, 20:37

AUSLESEN UND EINFÜGEN BEIM KALKULATOR v. 3 IST GEGLÜCKT!

Danke an das Toolkit von Falko und allen, die mitgewirkt haben!

Für Alle, die noch probleme haben, so geht's auf jeden Fall.

Wie hier beschrieben enthält man eine .txt Datei im "Output-Ordner". Diese File bitte öffnen und dann STRG + A für Alles markieren, dann STRG + C zum kopieren. Nun in den Kalkulator 3 gehen und zwar auf die Tabelle / Datenblatt "Dateieingabe". Dort in Spalte B alles entfernen und die kopierten Sachen einfügen! Nun sollte beim Datenblatt "Datenimport" die Einwohnerzahlen oder was auch immer ihr "ausgewertet" habt stehen. Super bequem und ohne lästige Zettelwirtschaft!

Problem hierbei ist leider nur, dass die Daten nicht auf das Datenblatt "Eingabe" übernommen werden, falls sich Jemand auskennt könnte derjenige vllt eine Verlinkung anbringen zu den Daten im "Datenblatt - Datenimport". Sonst muss ich mich selbst mal einlesen und es irgendwie versuchen!

Viel Spaß beim auslesen und einfügen der Daten ohne lästige Zettel.
knolle


PROBLEM BEI DER AKTION "ROUTE" ODER "AUTOROUTE"

ich weiß leider nicht genau wie diese Befehle zum Einsatz kommen, einfach nur auswählen, in PII wechseln und STRG + WIN + S drücken? Es heißt bei mir dann immer, dass eine *.txt Datei fehlt und aus dem hier werde ich leider nicht so schlau. Hat Jemand dazu eine Idee?

Auch das "Datenblatt - Konvoi_Manager" erschließt sich in diesem Zusammenhang nicht so.

Für eine Antwort wäre ich euch dankbar. Grüße

Falko

Forumtechniker

  • »Falko« ist männlich
  • »Falko« ist der Autor dieses Themas

Beiträge: 2 161

Dabei seit: 31. Dezember 2006

  • Private Nachricht senden

42

Mittwoch, 18. September 2013, 22:21


knoll3

Kaufmann

  • »knoll3« ist männlich

Beiträge: 245

Dabei seit: 25. August 2011

Wohnort: Südlich der Hansestädte

  • Private Nachricht senden

43

Donnerstag, 19. September 2013, 00:05

--> sehr wichtig, um zu verstehen, wie die Gesetzgebung der Formeln sein muss, um später mit dem "ROUTE-Befehl" alles auszuführen...

Falko, neee danke für dein Hinweis, was mich aber ein wenig beunruhigt. Es wäre dann ja so, dass man alle Befehle quasi schreiben muss und dann für ein Konvoiupdate die neuen Warenmengen aktualisiert und im Spiel dann einen neuen ROUTE=Stadt123 Befehl ausführt. Ich dachte eigentlich daran, dass man mit dem Kalkulator 3, dem Konvoimanager und dem Datenauslesen sofort in der Datei selbst (Kalkulator 3 Konvoimanager) eine Autoroute erstellen kann und diese dann im Spiel durch einen ROUTE=Stadt1234 Befehl ausführt und der PC dann alles selbst macht, sodass man nicht mehr das ständige aufschreiben und eingeben in den Autorouten im Spiel selbst vornehmen muss.

Grüße
knolle

Falko

Forumtechniker

  • »Falko« ist männlich
  • »Falko« ist der Autor dieses Themas

Beiträge: 2 161

Dabei seit: 31. Dezember 2006

  • Private Nachricht senden

44

Donnerstag, 19. September 2013, 01:14

der kalkulator kann diese texte generieren
diese text kann man einzeln pro route mit ROUTE=... starten dazu muss das passende schiff ausgewaehlt sein
bei vielen routen und voller konvoiliste funktioniert AUTOROUTE,v_,4 hier wird jeder konvoi ab position 4 autom. ausgewaehlt und absteigend die routen mit dem prefix v_ abgearbeitet da brauch man nix mehr tippen nur starten und 3 min kaffe trinken danach sind alle routen aktualisiert

knoll3

Kaufmann

  • »knoll3« ist männlich

Beiträge: 245

Dabei seit: 25. August 2011

Wohnort: Südlich der Hansestädte

  • Private Nachricht senden

45

Donnerstag, 19. September 2013, 11:28

der kalkulator kann diese texte generieren
diese text kann man einzeln pro route mit ROUTE=... starten dazu muss das passende schiff ausgewaehlt sein
bei vielen routen und voller konvoiliste funktioniert AUTOROUTE,v_,4 hier wird jeder konvoi ab position 4 autom. ausgewaehlt und absteigend die routen mit dem prefix v_ abgearbeitet da brauch man nix mehr tippen nur starten und 3 min kaffe trinken danach sind alle routen aktualisiert


Vielen Dank für die schnelle Antwort Falko zu so später Stunde ;-)!

Wie kann ich denn diese texte generieren? Ich glaube ja, dass es mit den "HYPERLINKS" zu tun hat, aber bei mir öffnet sich dann nichts oder es geschieht nichts. Daher kann ich sie nicht speichern oder die Konvoigröße, Vorhaltung in Wochen oder auch die Reserve verändern, wenn ich auf +10 oder +0,1 oder halt -10 oder -0,1 drücke.

Als Anhang mal meine Datei des Kalk version 3. Kalk3.ods

Falko

Forumtechniker

  • »Falko« ist männlich
  • »Falko« ist der Autor dieses Themas

Beiträge: 2 161

Dabei seit: 31. Dezember 2006

  • Private Nachricht senden

46

Donnerstag, 19. September 2013, 20:57

wennich mich recht entsinne gab es einen "button" konvoi_export der den export teil aufklappte
aber das ist schon was her

knoll3

Kaufmann

  • »knoll3« ist männlich

Beiträge: 245

Dabei seit: 25. August 2011

Wohnort: Südlich der Hansestädte

  • Private Nachricht senden

47

Donnerstag, 19. September 2013, 21:09

wennich mich recht entsinne gab es einen "button" konvoi_export der den export teil aufklappte
aber das ist schon was her


Stimmt den gibt es, ist nur leider bei mir Rot und es rührt sich gar nichts, wenn ich drauf klicke. Funktioniert es denn bei dir mit dem draufklicken und dann öffnet sich was?! Bitte mal eine Anleitung für den Konvoi Manager, wäre echt sau nett...

Muss ich eigentlich außer Java noch was installiert haben, Python oder sowas?

Grüße

Falko

Forumtechniker

  • »Falko« ist männlich
  • »Falko« ist der Autor dieses Themas

Beiträge: 2 161

Dabei seit: 31. Dezember 2006

  • Private Nachricht senden

48

Sonntag, 22. September 2013, 12:20

hab mal geschaut das mit dem anklicken funktioniert auf meiner uralten openoffice version 3.2 ohne probleme
in libreoffice 4.0 funktioniert dies nicht
warum wieso weshalb wie fixen .. hm erstmal keine ahnung
diese technik habe an gefuehlten 100 stellen angewandt das in irgendwas anderes umzuwandeln klingt nach viel arbeit
und ich bin arbeitsscheu daher habe ich ja auch das tool/kalkulator gebastelt
.. jaja ich bin einer der 4h investiert um eine stupide arbeit die in 2h gemacht ist zu automatisieren

knoll3

Kaufmann

  • »knoll3« ist männlich

Beiträge: 245

Dabei seit: 25. August 2011

Wohnort: Südlich der Hansestädte

  • Private Nachricht senden

49

Sonntag, 22. September 2013, 12:48

hab mal geschaut das mit dem anklicken funktioniert auf meiner uralten openoffice version 3.2 ohne probleme
in libreoffice 4.0 funktioniert dies nicht
warum wieso weshalb wie fixen .. hm erstmal keine ahnung
diese technik habe an gefuehlten 100 stellen angewandt das in irgendwas anderes umzuwandeln klingt nach viel arbeit
und ich bin arbeitsscheu daher habe ich ja auch das tool/kalkulator gebastelt
.. jaja ich bin einer der 4h investiert um eine stupide arbeit die in 2h gemacht ist zu automatisieren


Danke für Falko für deine Hilfe, du hast nicht zufällig noch eine Installtionsdatei von deiner Version auf deinem Rechner? Wenn nicht könnte ich vllt mal nachschauen, ob es diese Version noch im Internet gibt und mir diese dann besorgen, vielleicht liegt es ja an einem Update in den Versionen bis zur aktuellen 4.0, dass es nicht funktioniert.

Grüße und einen feinen Sonntag
knolle

Falko

Forumtechniker

  • »Falko« ist männlich
  • »Falko« ist der Autor dieses Themas

Beiträge: 2 161

Dabei seit: 31. Dezember 2006

  • Private Nachricht senden

50

Sonntag, 22. September 2013, 14:06

Danke für Falko für deine Hilfe, du hast nicht zufällig noch eine Installtionsdatei von deiner Version auf deinem Rechner? Wenn nicht könnte ich vllt mal nachschauen, ob es diese Version noch im Internet gibt und mir diese dann besorgen, vielleicht liegt es ja an einem Update in den Versionen bis zur aktuellen 4.0, dass es nicht funktioniert.
auf den ersten blick sehe ich hier http://www.openoffice.org/download/ den punkt "Old and legacy version: 3.4.1 + 3.3.0" probier doch eine davon aus

knoll3

Kaufmann

  • »knoll3« ist männlich

Beiträge: 245

Dabei seit: 25. August 2011

Wohnort: Südlich der Hansestädte

  • Private Nachricht senden

51

Sonntag, 22. September 2013, 17:12

Exportfunktion oder Makros in der Kalkulatordatei funktionieren nun! (noch keine 100%ige Sicherheit, weil ich selbst gerade erst darauf gestoßen bin wie es klappen könnte)

Ich denke, dass es daran liegt, dass der PC von Falko, der ja wohl die Datei erstellt hat, alle Makros bei sich auf dem Rechner gespeichert hat. Euer PC weiß dies noch nicht. Die Makros sind zwar in der Datei enthalten, aber können nicht umgesetzt oder angewandt werden. Ich weiß nicht, ob es dies wirklich ist, aber wenn Jemand es gerne mal ausprobieren möchte, dann zeige ich ihm oder ihr wie es gehen sollte. Einfach eine kurze Nachricht oder ein Post hier im Forum. Ansonsten gibt es bei google auch Anleitungen wie man die Markos von der Datei in den Ordner "Meine Makros" verschiebt. Ist dies geglückt, dann muss Open Office wohl einmal neu gestartet werden, um die Neuerungen anzunehmen.

Ich hoffe, dass das ständige aufschreiben, ausdrucken und dann von Hand einfügen im Spiel damit ein Ende hat.

Grüße und einen sau feinen Sonntag wünsche ich euch
knolle!

knoll3

Kaufmann

  • »knoll3« ist männlich

Beiträge: 245

Dabei seit: 25. August 2011

Wohnort: Südlich der Hansestädte

  • Private Nachricht senden

52

Mittwoch, 8. Januar 2014, 16:57

Problem mit dem Toolkit bei höherer Auflösung als 1280x1024 (z. B. mit 1680x1050, die durch das "Change Resolution" Programm von Falko geht)

Wenn ich bei einer höheren Auflösung als 1280x1024 einen Befehl mit dem Toolkit ausführen will z. B. DO=Baden, SUCH=KNEIPE, dann kommt leider immer "Auflösung passt nicht 1680"... kennt jemand das Problem und kann evtl abhilfe schaffen?

Ich finde es extrem gut das Spiel nun in einer höheren Auflösung spielen zu können, jedoch wäre es noch besser, wenn auch das Toolkit mit einer höheren Auflösung klar kommt.

Habt ihr ähnlich Probleme oder Erfahungen gemacht im Zusammenhang mit dieser Problematik?

Grüße
knolle

Ugh!

Perfektionator

Beiträge: 2 731

Dabei seit: 3. Juni 2005

  • Private Nachricht senden

53

Mittwoch, 8. Januar 2014, 18:16

Falcos Tool setzt man ja nur punktuell ein. Dafür schalte ich auf die Auflösung 800x600. Die Auflösung kennt und erkennt das Tool.

Nach dem Einsatz beende ich das Skript wieder, sonst meckert es in einer Tour wie bei dir.

Falls es dabei immernoch "nicht passende" Auflösung meldet: bei mir gab es Probleme, weil meine Taskleiste am rechten Bildschirmrand angezeigt wird. Die ist zwar in P2 garnicht zu sehen, stört aber trotzdem. Abhilfe: für den Tooleinsatz die Taskleiste an die gewohnte Position (unten) setzen.

x9jaan

Administrator

  • »x9jaan« ist männlich

Beiträge: 3 488

Dabei seit: 17. Februar 2006

Wohnort: Schnellmannshausen

  • Private Nachricht senden

54

Donnerstag, 9. Januar 2014, 16:38

Richtig, Falkos Tool kennt nur die drei Standardauflösungen. Ich hatte damals für Falko in den drei Auflösungen die jeweiligen Mauszeigerpositionen der Gebäude ermittelt. Wenn man Patrizier 2 in einem anderen Format betreibt, wird das Tool zwangsläufig daneben klicken und somit nicht funktionieren.
Die Schatzkarten als *-zip-Datei.

knoll3

Kaufmann

  • »knoll3« ist männlich

Beiträge: 245

Dabei seit: 25. August 2011

Wohnort: Südlich der Hansestädte

  • Private Nachricht senden

55

Donnerstag, 9. Januar 2014, 18:08

Falcos Tool setzt man ja nur punktuell ein. Dafür schalte ich auf die Auflösung 800x600. Die Auflösung kennt und erkennt das Tool.

Nach dem Einsatz beende ich das Skript wieder, sonst meckert es in einer Tour wie bei dir.

Falls es dabei immernoch "nicht passende" Auflösung meldet: bei mir gab es Probleme, weil meine Taskleiste am rechten Bildschirmrand angezeigt wird. Die ist zwar in P2 garnicht zu sehen, stört aber trotzdem. Abhilfe: für den Tooleinsatz die Taskleiste an die gewohnte Position (unten) setzen.


Richtig, Falkos Tool kennt nur die drei Standardauflösungen. Ich hatte damals für Falko in den drei Auflösungen die jeweiligen Mauszeigerpositionen der Gebäude ermittelt. Wenn man Patrizier 2 in einem anderen Format betreibt, wird das Tool zwangsläufig daneben klicken und somit nicht funktionieren.



Vielen Dank euch beiden für die schnelle Antwort :)

Grüße

56

Freitag, 10. Januar 2014, 17:25

18 Jahre alte CD raus gekramt ... Gott sei Dank, sie tut noch ihren Dienst,
installiert, Add-On drüber, 1.1 patch ... läuft :]
Toolkit und Kalk3 runter geheppt und auf nem alten savegame getestet...
Das ist ja wohl mal hammergeil!
Vor, keine Ahnung, gefühlten 6 Jahren das letzte mal gezockt und dazu kalkulator 2.0 genutzt, aber jetzt muss man scheinbar nur noch die Jäger und Baukonvois steuern, Papierkrieg adé.
Ganz großes Lob!!!

So ganz im ersten Anlauf hab ich zwar den türkisch Kurs und das mit den ins Spiel importieren der Routen nich raus bekomm, aber dazu gibts ja das Forum. :engel2:
Beim Baukurs erzählt mir das nette Toolkit was von falschem Savegame nachdem erfolgreich die Daten meiner alten Runde übernommen worden sind und das Kit nen Neustart bekam.
Ich les mich hier mal noch ein wenig ein und starte mal ne frische Runde (damals Add-On noch auf 1.0 gehabt...), vllt klappts dann ja.
Wenn nich geh ich euch aufn Keks. :D

Vielen Dank nochmal an Entwickler des Tools und Forenadmins etc.
ihr haltet den Klassiker immernoch so schön am Leben :170: :170: :170:

Bernd

x9jaan

Administrator

  • »x9jaan« ist männlich

Beiträge: 3 488

Dabei seit: 17. Februar 2006

Wohnort: Schnellmannshausen

  • Private Nachricht senden

57

Freitag, 10. Januar 2014, 19:13

18 Jahre alte CD raus gekramt ... Gott sei Dank, sie tut noch ihren Dienst,

Wow! Ich dachte ein gewisser Daniel van Bergen hat das Spiel als erster gehabt. Aber offenbar hat er nur die CD von dir kopiert, als er und Ascaron das Spiel im November 2000 auf den Markt brachten. ;)
Die Schatzkarten als *-zip-Datei.

58

Freitag, 10. Januar 2014, 20:39

Steht ja auch auf der Hülle und der CD Copyright 2000. Ach, mein Alzhi lässt grüßen... :oldman: War zumindest genug Staub drauf um 18 Jahre alt zu sein. :)
Habs aber mittlerweile raus bekomm mit Baukurs und Routen-Export. Freude!

Falko

Forumtechniker

  • »Falko« ist männlich
  • »Falko« ist der Autor dieses Themas

Beiträge: 2 161

Dabei seit: 31. Dezember 2006

  • Private Nachricht senden

59

Samstag, 11. Januar 2014, 02:43

Richtig, Falkos Tool kennt nur die drei Standardauflösungen.
haette es hier stadtscreenshots feedback gegeben waer ein einfacher umbau auf andere aufloesungen moeglich gewesen so gibts ein multi-aufloesungs-update erst wenn ich selber wieder zum p2 zocken komme :(

knoll3

Kaufmann

  • »knoll3« ist männlich

Beiträge: 245

Dabei seit: 25. August 2011

Wohnort: Südlich der Hansestädte

  • Private Nachricht senden

60

Samstag, 11. Januar 2014, 10:38

Richtig, Falkos Tool kennt nur die drei Standardauflösungen.
haette es hier stadtscreenshots feedback gegeben waer ein einfacher umbau auf andere aufloesungen moeglich gewesen so gibts ein multi-aufloesungs-update erst wenn ich selber wieder zum p2 zocken komme :(


Mach dir bitte keinen Stress Falko, wir sind im Forum ja alle glücklich :170: :ola: , dass es überhaupt so ein Tool gibt und zur Not kommt man (ich) auch mit der Auflösung 1280x1024 oder was das war klar. Also, danke nochmal für die Hilfe, ich hatte nur im Kopf, ob man es nicht auch einfach so mit einer höheren Auflösung schaffen könnte das Kit zu benutzen.

Schönes Wochenende :wave2: